wordpress教程

WordPress 5.5功能失效+js报错解决方法

精准像素 2020-08-21 人阅读

WordPress升级到5.5以后,网站的某些功能失效了,通过浏览器调试工具查看,会发现一些js报错。

其实主要的原因是,WordPress 5.5删除了jQueryMigrate1.x。如果您使用jQuery,请确保您不依赖jQuery Migrate 1.x单独提供的任何功能。

但是有些主题或插件使用了比较老旧的jQuery函数,以前一直都采用jQuery Migrate1.x做兼容处理的,但是现在WordPress 5.5+ 默认禁用了这个兼容库,所以就出现问题了。

WordPress 5.5功能失效+js报错解决方法

WordPress报错解决方法

尽快更新使用新的jQuery函数,解除对jQuery Migrate1.x的依赖。

WordPress官方团队专门开发了一个小插件 Enable jQuery Migrate Helper,只需要安装和启用插件,就可以继续加载 jQuery Migrate1.x,让你的网站避免出现js错误。

不过,建议普通用户可以联系一下主题和插件作者,提醒他们更新代码,这样才是最好的做法。